Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About IANA-Maintained MIBs Last Updated 2026-09-30 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • IANA-ADDRESS-FAMILY-NUMBERS-MIB • IANA-BFD-TC-STD-MIB • IANA-CHARSET-MIB • IANA-ENERGY-RELATION-MIB • IANA-ENTITY-MIB • IANA-FINISHER-MIB • IANA-GMPLS-TC-MIB • IANA-IPPM-METRICS-REGISTRY-MIB • IANA-ITU-ALARM-TC-MIB • IANA-LANGUAGE-MIB • IANA-MALLOC-MIB • IANA-MAU-MIB • IANA-POWER-STATE-SET-MIB • IANA-PRINTER-MIB • IANA-RTPROTO-MIB • IANA-SMF-MIB • IANA-STORAGE-MEDIA-TYPE-MIB • IANAifType-MIB • IANAolsrv2LinkMetricType-MIB • IANATn3270eTC-MIB • IANA-GBOND-TC-MIB IANA-ADDRESS-FAMILY-NUMBERS-MIB Created 1999-08-26 Registration Procedure(s) See the [Address Family Numbers] registry. Reference [RFC 2677] Registry File(s) ianaaddressfamilynumbers-mib IANA-BFD-TC-STD-MIB Created 2014-06-06 Last Updated 2025-11-25 Registration Procedure(s) IETF Review Reference [RFC 7330] Note See the [BFD Diagnostic Codes and BFD Authentication Types] registries. Registry File(s) ianabfdtcstd-mib IANA-CHARSET-MIB Created 2004-06-08 Last Updated 2021-01-04 Registration Procedure(s) See the [Character Sets] registry. Reference [RFC 3808] Registry File(s) ianacharset-mib IANA-ENERGY-RELATION-MIB Created 2014-12-29 Last Updated 2015-03-26 Registration Procedure(s) Specification Required Expert(s) Unassigned Reference [RFC 7461] Registry File(s) ianaenergyrelation-mib IANA-ENTITY-MIB Created 2013-02-27 Last Updated 2022-12-01 Registration Procedure(s) Expert Review Expert(s) Andy Bierman (primary), Jürgen Schönwälder (secondary) Reference [RFC 6933] Registry File(s) ianaentity-mib IANA-FINISHER-MIB Created 2004-06-02 Last Updated 2014-05-22 Registration Procedure(s) Expert Review Expert(s) Ira McDonald, Michael Sweet Reference [RFC 3806] Registry File(s) ianafinisher-mib IANA-GMPLS-TC-MIB Created 2007-02-27 Last Updated 2014-11-04 Registration Procedure(s) See individual [GMPLS registry] procedures. Reference [RFC 4802] Registry File(s) ianagmplstc-mib IANA-IPPM-METRICS-REGISTRY-MIB Created 2005-04-12 Last Updated 2015-08-14 Registration Procedure(s) This module has been designated Obsolete. The registry will no longer be updated, and the current contents will be maintained as-is. Reference [RFC 4148][RFC 6248] Registry File(s) ianaippmmetricsregistry-mib IANA-ITU-ALARM-TC-MIB Created 2004-09-09 Last Updated 2014-05-22 Registration Procedure(s) Expert Review Expert(s) Unassigned Reference [RFC 3877] Registry File(s) ianaitualarmtc-mib IANA-LANGUAGE-MIB Created 1999-09-09 Last Updated 2023-08-25 Registration Procedure(s) Expert Review Expert(s) Juergen Schoenwaelder, David Levi Reference [RFC 3165] Registry File(s) ianalanguage-mib IANA-MALLOC-MIB Created 2003-01-27 Last Updated 2014-05-22 Registration Procedure(s) Expert Review or RFC Required Expert(s) Dave Thaler Reference [RFC 3559] Registry File(s) ianamalloc-mib IANA-MAU-MIB Created 2007-04-21 Last Updated 2026-07-15 Registration Procedure(s) Expert Review Expert(s) Marek Hajduczenia (primary), Operations and Management Area Directors (backup) Reference [RFC 4836] Registry File(s) ianamau-mib IANA-POWER-STATE-SET-MIB Created 2014-12-29 Last Updated 2022-01-28 Registration Procedure(s) See the [Power State Sets] registry group. Reference [RFC 7460] Registry File(s) ianapowerstateset-mib IANA-PRINTER-MIB Created 2004-06-02 Last Updated 2024-02-06 Registration Procedure(s) Expert Review or RFC Required Expert(s) Ira McDonald, Michael Sweet Reference [RFC 3805] Registry File(s) ianaprinter-mib IANA-RTPROTO-MIB Created 2000-09-26 Last Updated 2016-04-25 Registration Procedure(s) Expert Review or RFC Required Expert(s) Dave Thaler Reference [RFC 2932] Registry File(s) ianaiprouteprotocol-mib IANA-SMF-MIB Created 2014-08-14 Last Updated 2014-10-14 Registration Procedure(s) IANAsmfOpModeIdTC: First Come First Served. IANAsmfRssaIdTC: 1-127, Standards Action; 128-239, Reserved for Private or Local Use; 240-255, Experimental RFC. Reference [RFC 7367] Registry File(s) ianasmf-mib IANA-STORAGE-MEDIA-TYPE-MIB Created 2015-08-13 Last Updated 2016-06-17 Registration Procedure(s) Expert Review Expert(s) Unassigned Reference [RFC 7666] Registry File(s) ianastoragemediatype-mib IANAifType-MIB Created 1994-01-31 Registration Procedure(s) This is one of the available formats of the [Interface Types (ifType) and Tunnel Types (tunnelType)] registries. Expert(s) Dave Thaler Reference [RFC 2863][RFC 8892] Registry File(s) ianaiftype-mib IANAolsrv2LinkMetricType-MIB Created 2013-07-02 Last Updated 2022-01-28 Registration Procedure(s) See the [LINK_METRIC Address Block TLV Type Extensions] registry. Reference [RFC 7184] Registry File(s) ianaolsrv2linkmetrictype-mib IANATn3270eTC-MIB Created 1999-09-01 Last Updated 2014-05-22 Registration Procedure(s) Working Group Review (see DESCRIPTION clause associated with the MODULE-IDENTITY statement) Reference [RFC 2561] Registry File(s) ianatn3270etc-mib IANA-GBOND-TC-MIB Created 2012-08-12 Last Updated 2017-06-23 Registration Procedure(s) Expert Review Expert(s) Unassigned Reference [RFC 6765] Registry File(s) ianagbondtc-mib Licensing Terms